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Notes To Readers
The QuickstepTM User Guide provides the following information:

• An overview of the Quickstep editor, Parameter editor, Data Table editor,
and Symbol Browser.

• Step-by-step instructions explaining how to set up the parameters for your
Quickstep program.

• Step-by-step instructions showing how to create a Quickstep program, define
symbolic names, and create a Data Table

• Step-by-step instructions for compiling and downloading your Quickstep
program to a controller.

• Step-by-step installation instructions.

Related Documents
The following documents contain additional information

• For information on Quickstep, refer to the QuickstepTM Language and
Programming Guide.

• For information on your controller and its modules, refer to the appropriate
Installation and Applications Guide.

• For information on the registers in your controller refer to the Register
Reference Guide (available at www.control.com).

• For information on the DeviceNet configurator, refer to the DeviceNet
Configurator User Guide.

• For information on Microsoft Windows or your PC, refer to the manuals
provided by the vendor.
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Notes to Readers

Book conventions
The following conventions are used in this book:

ALL CAPS BOLDFACE Identifies DOS, Windows, installation program file names.

Boldface Indicates information you must enter, an action you must perform,
or a selection you can make on a dialog box.

Italics Indicates a word requiring an appropriate substitution.  For
example, replace filename with an actual file name.  It can also
indicate a manual, book, or chapter title.

Text_Connected_With_Underlines Indicates symbolic names used in Quickstep programs.  Step
Names are ALL_CAPITALS.  Other symbolic names can be
Initial_Capitals or lower_case.

SMALL CAPS Identifies the names of Quickstep instructions in text.

Courier font Identifies step names, comments, output changes, and QuickALL
CAPS BOLDFACE Identifies DOS, Windows, installation
program file names.

ArtCode – DN-24 Identifies the file name of a particular graphic image.

How to Contact Control Technology Corporation
Control Technology Corporation is located in Massachusetts, and wer are open
from 8:30 a.m. to 5:00 p.m. eastern time. Contact us at 508 435-9595 and 800
282-5008 or Fax 508 435-2373

See us on the web at www.ctc-control.com.

Your Comments
We welcome your suggestions and comments about this or any other Control
Tech document. Comment forms are in the file called BUGRPT.WRI, which was
installed in your QSWIN directory during your Quickstep installation. you can
also email comments to techpubs@control.com.
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As part of the installation QSSETUP.EXE creates a Quickstep program group.

To launch the Quickstep editor:

1. Open the Quickstep program group and select the Quickstep icon

2. Click the mouse twice to launch the Quickstep editor

Starting the Quickstep editor displays the editing window, the Parameter editor
and the icon for the minimized Symbol Browser.

NOTE: Installation instructions are in the Release Notes provided with your Quickstep program disks.
They are also included in Appendix A.

Parameter Editor
The Parameter editor allows you to specify information about your Quickstep
program and your controller:

• The model of your controller
• The number of rows and columns in data table
• Any dedicated inputs assigned

After you select the controller model, the Parameter editor can list the
controller’s limits.

When you start the Quickstep editor or open a new Quickstep program file, the
editor displays the Parameter editor.  You cannot minimize the Parameter editor
until you:

• Specify a controller model and select Ok when beginning a new Quickstep
program.

• Open an existing Quickstep program.

Symbol Browser
The Symbol Browser allows you to specify step names, as well as symbolic
names used in your program.  Symbolic names can identify the function of the
numeric values, controller resources and specialized devices.  For example, an
output that controls a pneumatic cylinder for a stamping press can be called
stamp_press_on and stamp_press_off.

NOTE: Outputs need two symbolic names, one for turning the output on and another for turning it off.
Inputs can have two symbolic names, one for the normally open and another for the normally
closed state.

You can also give servo motors different symbolic names, e.g., traverse, rotate,
spindle, rather than call them servo_1, servo_2, and servo_3.

Data Table Editor
The Data Table editor allows you to enter information for a data table.  In a new
Quickstep program, the Data Table editor does not appear until you select Data
Table from the View menu.  It automatically appears when you open a program
that has a Data Table already defined.

Launching the Quickstep Editor
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Editor Screen Overview

Menu bar - Contains the File, Edit, View,
Search, Project, and Help menus.

Title bar - Displays the application name
and the name of your Quickstep program.

Toolbar - Gives you
quick mouse access to
many tools used in the
Quickstep editor.
Display or hide the
Toolbar by selecting
Toolbar from the View
menu.

Selection bar - Lists
the Quickstep
instructions, the
parameters for each
instruction as you
program it, and
displays the symbolic
names.

Editing window -
Displays your
Quickstep program.
This is the area
where you view and
edit your file.

Status bar - Shows messages to help you use the Quickstep editor and provides statistics
about the insertion point position and the status of some important keys.  Display or hide
the Status bar by selecting Status Bar from the View menu.

The following illustration shows the Quickstep editor window and describes the
different parts of the window.
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The Selection Bar
When you program step names, output changes, and Quickstep instructions, the
Selection bar displays the appropriate choices.  You can select among those
choices using either the keyboard or mouse as explained below.

The Selection bar is empty until you select an empty
placeholder or choose an option from the Edit menu,
Search menu, Shortcut menu, or Toolbar.

After you choose an option, the Selection bar displays
the appropriate selections or choices.

To start using the Selection bar to program a step, highlight an empty <<New
Step Name>>, <<Output Change>>, or <<Statement>> placeholder with the
mouse pointer and do one of the following:

• Double click the left mouse button.
• Press Enter.

The Selection bar will display the appropriate selections.

As you program an instruction, the Selection bar first displays the list of quick-
step instructions, then it displays the possible choices for each parameter.

NOTE: For examples showing how to use the Selection bar to specify step names and output changes
and to program instructions, see Chapter 4, Using the Quickstep Editor - Writing a Quickstep
Program.

Editor Screen Overview
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The Toolbar
The Toolbar appears across the top of the Quickstep editor window, below the
menu bar.  It contains the following tools:

New - Opens a new Quickstep program file.

Open Existing File - Opens an existing Quickstep program. The editor displays
the Open dialog box.

Save - Saves the active program with its current name.  When saving a new
program, the editor displays the Save As dialog box.

Print - Displays the Print dialog box to print the current Quickstep program.

Cut - Removes the selected text and places it on the Clipboard

Copy - Copies the selected text and places it on the Clipboard

Paste - Inserts the contents of the Clipboard in the program file.

Insert After - Inserts a new comment line, output change, or statement place-
holder (instruction) after the current line.

Insert Before - Inserts a new comment line, output change, or statement place-
holder (instruction) before the current line.

Insert Step After - Inserts a new step after the current step.

Goto Step - Goes to the step whose name is highlighted.

Find Reference - Finds the next occurrence of the symbolic name specified by
Find Symbol.

About the Quickstep editor - Displays the program information for the Quickstep
editor, version number, and copyright.

Help Button - Gives you information about parts of the editor screen and Toolbar.

To hide or display the Toolbar, choose Toolbar from the View menu.
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Editor Screen Overview

The Shortcut Menu
The Shortcut menu gives you fast access to Quickstep editor commands.  It
appears when you highlight an entire line or part of a line or a placeholder in the
editor window and press the right mouse button.

From the Shortcut menu you can select the following options:

• Replace the highlighted selection with another Quickstep instruction or a
parameter or operator for the instruction.

• Delete the selected text from a line or step.

• Insert a new comment, output change, or statement line before or after the
current line.

• Delete a comment, output change, or statement line.

• Activate the Line editor to edit an output change or instruction.

• Insert a new <<Statements>> placeholder before any other instructions in a
step.

• Insert a new step before or after the current step.

• Go to a step

The options on the Shortcut menu change and some selections may be grayed
out, depending on the previous command the editor executed, and where the
cursor is in the editing window.  For example, when the cursor highlight is on an
output change line, the Shortcut menu appears as follows:
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Starting a New Editing Session
Starting the Quickstep editor displays the editing window, the Parameter editor
and the icon for the minimized Symbol Browser.  When starting a new editing
session you should:

• Use the Parameter editor to specify the model of your controller, the number
of rows and columns in a data table, and any dedicated inputs.

• Specify symbolic names.  You can specify symbolic names in the process of
writing your program.  However, we recommend you use the Symbol
Browser to define the names of controller resources you will be referring to
often.

• Start writing your Quickstep program.

• If you are using a Data Table, enter values in the Data Table.

Programming a Step
When you start the Quickstep editor, it displays a step with all of its
placeholders empty.  A Quickstep program uses steps to define each new state of
a machine.  A complete program is made up of a series of steps executed in a
defined pattern or specific sequence.  You program a step by selecting each
placeholder.  Steps should be programmed in order, starting with the step name.

Summary of operations to program a new step:

• Enter the step name.  Step names are optional, but Control Tech strongly
recommends you use them.  If you have not previously defined a symbolic
name for the step, the editor allows you to define it as you program the step.

• Enter any comments for the step.  You can edit comments later, using the
comment editor.

• Specify the output change(s).  The output change can be one of the follow-
ing: turn all outputs off, do not change the current state of the outputs, or
turn specific outputs on or off.  You must select one of these three choices
for each step.

• Enter the instructions for this step.

If you have not already defined them, you can define symbolic names while you
program a step.

For step-by-step examples showing how to enter a step name, comments, output
changes, instructions, and symbolic names, see Chapter 4.

Comment line placeholder

Step name placeholder

Output change placeholder

Statements placeholder (for
Quickstep instructions)

Step number
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Converting an Existing Quickstep Program
You can convert a Quickstep 1.6 or 1.7 program to a Quickstep 2.0 program by
opening it with the Quickstep 2.0 editor.  After converting a program, you should
look for the following changes:

• The Quickstep 2.0 editor changes the counter, register, etc. names to sym-
bolic names, such as ctr#2 to ctr_2.  You should change these names to ones
appropriate to your application.

• Instructions and input/output changes that the Quickstep 2.0 editor could not
convert properly (called unparsed source) are displayed in red text (system
default).

NOTE: If you have changed the default color for Unparsed Source, unconverted lines are displayed in
that color.
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Parameter Editor Overview
When you start the Quickstep editor, it automatically activates the Parameter
editor.  Use the Parameter editor to specify and display the following informa-
tion:

• The model of your controller
• The number of rows and columns in a data table
• Which, if any, of the first four inputs are used for dedicated functions
• Specific limits for your controller

Displays a list of
possible controller
models.

Specifies if inputs one through four are
used for dedicated input functions.  You
can select as many of these functions
as your application requires.

Displays the help file for
the Parameter editor.

Displays the maximum number
of inputs, outputs, servo motors,
etc. your controller can control.

Specifies the
number of
rows and
columns in a
data table.

Cancels the
selections you just
made.

Saves the selections you
have made in the Parameter
file for the current Quickstep
program.

When you open a new Quickstep program file or start the Quickstep editor, it
displays the Parameter editor.  You cannot minimize the Parameter editor until
you:

• Specify a controller model and select Ok when beginning a new Quickstep
program.

• Open an existing Quickstep program.

Title Bar
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Specifying Parameters
Specifying the Controller Model

Controller Model field allows you to specify the model of controller you are
using.  To select the controller model:

1. Click the arrow on the right side of the controller field to display a list of
controller models.

2. Select your controller model by clicking it with the mouse.

The Parameter editor displays the controller model in the field.

3. After you select any other parameters you want (e.g., Data Table param-
eters), select the OK button.

Specifying Dedicated Input Functions
You can also assign inputs one through four as dedicated inputs.  These func-
tions are triggered automatically when an external switch connected to the
appropriate input closes.  The inputs are as follows:

• Start on Input #1:  Starts or continues execution of a program.

• Stop on Input #2:  Stops the execution of a program.

• Reset on Input #3:  Re-initializes the controller and starts executing the
program at the first step.

• Step on Input #4:  Advances the controller one step in the program.

The inputs are active at every step of your Quickstep program, subject to the
priorities and rules listed for each input.  See the Quickstep Language and
Programming Guide for additional information on dedicated input functions.

To select an input:

1. Select the box (by clicking it with the mouse) next to the dedicated input
function you want.
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The box is filled with an X.

2. Select the box next to any other dedicated input functions you want

3. After you select any other parameters you want (e.g., Data Table param-
eters), select the OK button.

Specifying Data Table Parameters
You specify the number of columns and rows in a Data Table from the Parameter
editor.

IMPORTANT! • The value of all the cells in a new Data Table are set to zero.

• If you resize a Data Table by making it smaller, any information in the
rows and/or columns outside of the resized Data Table is lost.

• If you resize a Data Table by making it larger, the cells in the new rows
and/or columns are set to zero.

To specify the columns and rows:

1. Place the cursor in the Data Table Cols field using one of the following
methods:

• Press the Tab key until it is highlighted.
• Select the field with the mouse pointer and delete the zero.

2. Enter the number of columns in the data table.

3. Place the cursor in the Data Table Rows field.

4. Enter the number of rows in the data table.

Specifying Parameters
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5. After you select any other parameters you want (e.g., dedicated input
parameters), select the OK button.
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Opening a New Quickstep Program File
To open a Quickstep Program file:

1. Do one of the following:

• Choose New from the File menu (shortcut, type CTRL + N).
• Choose the New icon on the Toolbar.

2. Select OK.

REMEMBER: You must specify the controller model from the Parameter editor when opening a new
file.

Opening an Existing Quickstep Program File
To open an existing Quickstep program file:

1. Do one of the following:

• Choose Open from the File menu (shortcut, type CTRL + O).
• Choose the Open icon on the Toolbar.

 
• Select a file from the Recent file list at the bottom of the File menu.

2. When the Open dialog box appears, type or select the document you want to
open in the File Name box.

If the document you want to open is not listed in the File Name box, select
the appropriate directory and/or drive.

3. Select OK.

Opening Files
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Saving Quickstep Programs
You can save a new Quickstep program file by using the Save As command.  The
Quickstep editor calls new, unnamed files qsedit.dsp.  You can save an existing
file by selecting the Save command.  Save records any changes you make to an
active file, and the file name and location remain the same.  You should save
files frequently as you work.

Saving a New, Unnamed File
To save a new unnamed file:

1. Do one of the following:

• Choose Save As from the File menu.
• Choose the Save icon on the Toolbar.

2. When the File Save As dialog box appears, enter a name for the new file.

3. If you want to save the file in a different directory, select the appropriate
directory.

4. Select OK.

Saving an Active File
To save the file, choose one of the following:

• Choose the Save icon on the Toolbar.

• Choose Save from the File menu (shortcut, type CTRL + S).

Reverting to the Last Saved File
Revert returns your Quickstep program to the last saved version of the program.
When you revert to a previous version of your program, all changes you have
made since the last save are gone.

To revert to the last saved version, choose Revert from the File menu.

Using the Backup File
The Quickstep editor also creates a backup version of your program.  Backup
files are located in the directory where you saved your Quickstep program in a
subdirectory called QSBACKUP.  The backup file is a copy of your Quickstep
program prior to your most recent save.
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Printing a Quickstep Program
You can print a Quickstep program:

1. Do one of the following:

• Select the Print icon on the Toolbar.

• Choose Print from the File menu (shortcut, type CTRL + P).
2. When the Print dialog box appears, select one of the following:

• Choose All to print the entire program file.

• Choose Pages and specify the numbers of the page numbers you want to
print.

3. Select OK.

Selecting a Printer and a Printer Connection
Print Setup allows you to select a printer and a printer connection.  It gives you
the following options:

• Default Printer - Lists the name of the default printer.
• Specific Printer - Provides a list of installed printers
• Orientation - Specifies the printing orientation.
• Paper Size - Specifies the paper size.
• Paper Source - Specifies the paper source, paper tray, manual feed, etc.
• Options - Provides access to other printing options for the printer you select
• Network - Provides access to other printers on a network.

To select a printer and printer connection:

1. Select Print Setup from the File menu.

2. When the Print Setup dialog box appears, select options you want.

3. Choose OK.

Printing Quickstep Program Files
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Previewing a File Before Printing
Print Preview allows you to see how a file will look before you print it.

The Quickstep editor displays the Print Preview bar across the top of the Editing
window when you choose this option.  In Print Preview, the cursor appears as a
magnifying glass when it is in the editing window.

To view a Quickstep program before printing:

1. Select Print Preview from the File menu.

2. Choose the view options you want.

3. To display the Print dialog box and print the file, select Print.

4. To return to editing mode, select Close.

To control the display of pages, select the buttons or press keys.

Button Key Function
Print P Opens the Print dialog box.

Next Page N Displays the next page.

Prev Page V Displays the previous page.

Two Pages T Switches to a two-page display.

One Page O Switches to a one page display.

Zoom In  I Zooms in on the page display.  You can zoom in twice.
The Prev Page, One Page, and Two Page buttons are
hazed out when you zoom in.

Zoom Out O Zooms out the page display.

Close C Ends print preview and returns to the normal view.



3-6 QuickstepTM User Guide
Control Technology Corporation proprietary. Reproduction or distribution forbidden.

Closing Files and Exiting the Quickstep Editor
Closing a File

There are two ways to close a Quickstep program file:

1. Open another Quickstep program file.

2. Exit the Quickstep Programming Editor, using one of the following meth-
ods:

• Choose Exit from the File menu.

• Press ALT + F4.

• Double-click the Application Control-menu.

IMPORTANT! If you open another Quickstep file without saving the current, active file, your changes
will be lost.

Exiting the Quickstep Programming Editor
Choose Exit from the File menu to exit the Quickstep programming editor.
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Changing Editor Field Colors
The Quickstep editor displays program items such as, comment lines, the current
field, in different colors.  You can change the default colors using the QSEditor
Properties dialog box.

If you change the default colors, you should always have the color for the
current field and for Unparsed Source as distinct colors.  This way you can
quickly see which field is the current field and if any lines were not parsed by
the editor.  Cyan with black text is the default for the current field, and white
with red text is the default for Unparsed Source.

To change Quickstep editor display colors:

1. Choose Properties from the Edit menu.

The QSEditor Properties dialog box appears.

2. Select the program item whose color you want to change.

The sample text box displays the current text (foreground) color and
background color.

3. Select the new Foreground Colors and/or Background Colors.
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The Sample Text box displays your changes.

4. Continue selecting program items whose color you want to change.

5. To apply your changes, do one of the following:

• Press Enter.

• Select OK.
6. To exit without saving your changes, select Cancel.

Changing Editor Field Colors
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When you begin writing a Quickstep program, the Quickstep editor displays a
step with all of its placeholders empty.  You program a step by selecting each
placeholder in order, beginning with the step name, and filling in the required
information.

Summary of operations to program a new step:

• Enter the step name.  Step names are optional, but Control Tech strongly
recommends you use them.  If you have not previously defined a step name,
the editor allows you to create them as you program the step.

• Enter any comments for the step.  You can edit comments later, using the
comment editor.

• Specify the output change.  The output change can be one of the following:
turn all outputs off, do not change the current state of the outputs, or turn
specific output(s) on or off.  You must select one of these choices for each
step.

• Enter the instructions for this step.

If you have not already defined them, you can define symbolic names for steps,
outputs, inputs, controller resource, and specialized I/O and motion control
devices while you program a step.

Using the Selection Bar
When you program step names, output changes, and Quickstep instructions, the
Selection bar displays your choices and allows you to select among them.  To
start using the Selection bar to program a step, place the mouse pointer on an
empty <<New Step Name>>, <<Output Change>>, or <<Statement>>
placeholder and do one of the following:

• Double click the left mouse button .
• Select the placeholder with the mouse pointer and press Enter.

The Selection bar will display the appropriate selections.  It only displays the
symbolic names that could possibly be used at that time.  For example, it only
lists the symbolic names for outputs when you are specifying an output change.

Programming a Step

Comment line placeholder

Step name placeholder

Statements placeholder
(for Quickstep instructions)

Output change placeholder

Step number
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Listing and Selecting Items in the Selection Bar
To list or select items from the Selection bar and enter them in a placeholder, use
one of the following methods:

• Place the mouse pointer on the item and double click the mouse.

• Select the item with the mouse pointer and press Enter.

• Press the Tab key to move the focus to the list of options displayed in the
Selection bar.  Use the Arrow keys to highlight the item and press Enter.

• Type the name of the item.  Once you have entered enough letters to
uniquely identify the item, it appears in the Selection box.  Press Enter.

Selection Bar Choices - Data Sources and Destinations
As you program steps, the Selection bar displays different options depending on
what part of an instruction you are programming.  Some Quickstep instructions
can obtain and send data to and from a variety of locations.  These locations are
listed in the Selection bar as follows:

Numeric Source: A numeric source supplies a numeric value.  It can be a
servo position or error, a numeric constant, or the value
derived from a counter, register, analog input, thumbwheel,
or Data Table column.

Data Destination: A data destination accepts a numeric value.  It can be a
register, counter, analog output, display, or a value entered
into a Data Table column.

Resource Delay: A resource delay is any controller resource or specialized I/
O device that provides the value for a DELAY instruction.

Data Source: A data source supplies a numeric value and is a Numeric
Source.  It can be a numeric constant or the value derived
from a counter, register, analog input, thumbwheel, or Data
Table column.

Servo Value: A servo value is the servo position or error and is a Numeric
Source.

Selection Bar Choices - Immediate Actions
In some cases, the choices in the Selection bar allow you to delete placeholders
for optional parameters in an instruction or provide options for completing the
output change or instruction.  Immediate action selections are as follows:

= = > All Off Enters <TURN OFF ALL DIGITAL OUTPUTS> in the
output change line.  If there are any output changes in the
step, it deletes them.

= = > No Changes Enters <NO CHANGE IN DIGITAL OUTPUTS> in the
output change line.  If there are any output changes in the
step, it deletes them.

= = > Finish Deletes any placeholders for optional parameters left in an
instruction.  You can only use this if all required parameters
are specified

= = > Delete Deletes a highlighted placeholder for an optional parameter
in an instruction.
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The Current Field
The Quickstep program, as it appears in the Quickstep editor window, is com-
posed of a number of fields (software professionals may think of these as
“tokens”).  As you work in the Quickstep editor window, you may move a cursor
from one field to another by using the arrow keys on your computer. The field to
which you have moved the cursor is known as the “current field.”  The current
field is indicated by displaying it in a unique color scheme.

When a placeholder is displayed in this color scheme, it is the current field.
Step headers, output lines, comments and instructions are also made up of fields.
Comment and output lines are considered one field.  A step header has two
fields, the step number and step name.  Each parameter in an instruction is
considered a separate field.  For example, the instruction–monitor
partsensor goto next–actually consists of four fields:

• The instruction name: monitor
• The input name: partsensor
• The instruction token: goto
• The destination of the instruction: next

You can modify how the current field cursor is displayed by changing its colors,
so that it may be displayed in any color you choose.  For information on chang-
ing the colors of fields, see Changing Editor Field Colors in Chapter 3, Quick-
step Editor Basics.

Programming a Step
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Defining Symbolic Names
The Quickstep editor uses symbolic names for step names, numeric constants,
controller resources, and specialized I/O and motion control devices.  You can
specify symbolic names in the process of writing your program.  Symbolic
names defined using this method are automatically entered in the Symbol Table.
However, we recommend you use the Symbol Browser when defining several
symbolic names at once.  For information on using the Symbol Browser, see
Chapter 6, Using the Symbol Browser.

IMPORTANT! Each symbolic name must be unique, and within a symbol type (e.g., servos, registers)
each numeric must be unique.  This means you can only have one symbolic name for
register 10.  Inputs and outputs each have two possible states, and each state can be
given a unique symbol name.

An exception to this rule is numeric constants.  You can have two numeric constants one
called Over_Pressure with a value of 5000 and another called Base_Velocity with a value
of 5000.

You can define symbolic names from the Quickstep editor by selecting New
Symbol from the Edit menu.  This displays the Define New Symbol dialog box
and allows you to define new symbolic names.  This example defines a symbolic
name for a flag.  For an example showing how to define a symbolic name while
you are programming an instruction, see Defining Symbolic Names When
Programming an Instruction in this chapter.

To define symbolic names:

1. Choose New Symbol from the Edit menu.

The Define New Symbol dialog box appears.

2. To enter a new symbolic name, do one of the following:

• Click the arrow on the right side of the Name field to display a list of
symbolic names and select an existing symbol name to edit

• Type the symbolic name in the Name field.

3. Press Tab to go to the next field.
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4. Click the arrow on the right side of the Type field to display a list of
symbol types and select the symbol type by clicking it with the mouse
pointer.

The Type field displays the symbol type and the highlight moves to the
Number field.

5. Type the number of the controller resource or device in the Number field.

6. Select OK to enter the symbolic name.

NOTE: If the correct Type is already displayed, you can skip steps 3 and 4.

Defining Symbolic Names
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Step names are optional, but Control Tech strongly recommends you use them.
If you have not previously defined a symbolic name for a step, the editor allows
you to define it as you program the step.

NOTE: Control Tech’s support of step numbers in DO and GOTO instructions is for backwards compat-
ibility only.  Future releases of Quickstep will require step names in step headers and in DO and
GOTO instructions.

If you have previously defined step names using the Symbol Browser, they
appear in the Selection bar.  If not, the selection bar is blank and you must define
a step name now.

Entering a New Step Name
To enter a new step name:

1. Place the mouse pointer on the <<New Step Name>> placeholder and do
one of the following:

• Double click the left mouse button.
• Select the placeholder with the mouse pointer and press Enter.

2. Type the Step Name.  It appears in the Selection box; the editor automati-
cally enters underlines for spaces.

3. Press Enter when you are done.

The editor inserts the step name.

Entering a Previously Defined Step Name
To enter a previously defined step name:

1. Place the mouse pointer on the <<New Step Name>> placeholder and do
one of the following:

• Double click the left mouse button.

• Select the placeholder with the mouse pointer and press Enter.

Entering Step Names
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Entering Step Names

2. Select the Step Name using the mouse or keyboard  The editor places it in
the Selection box.

3. Press Enter to insert the name in the step.
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The Comment Editor
The Comment editor window appears when you are entering a new comment or
editing an existing one.

Comment Editor Menus
The menu bar contains the File, Edit and Help menus.  Using these menus you
can

• Insert comments into your Quickstep program
• Cut, copy and paste text in the editor
• Display the Help file for the Comment editor.

Selecting File displays the following menu:

• Exit Saving Changes: enters the new or edited comment in the comment
line.

• Exit Discarding Changes: exits the Comment editor without changing the
existing comment line or comment line placeholder.

WARNING! Exiting the Comment editor by double clicking on the Application Control menu button or
using ALT + F4 keys does not save your changes.  You must select Exit Saving Changes
from the File menu to save comments.

Entering Comments

Editing Window - Displays the text of your comment lines.
Use this area to enter and edit your comment lines.

Menu Bar - Contains the File, Edit and Help menus.
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Selecting Edit displays the following menu:

• Cut: removes selected text and places it on the clipboard.  The text you
place on the Clipboard remains there until you replace it with a new item.

• Copy: copies selected text to the Clipboard. The text you place on the
Clipboard remains there until you replace it with a new item.

• Paste: inserts a copy of the Clipboard contents at the insertion point, If you
have highlighted any text, the editor replaces the selection with the text on
the Clipboard. You cannot use paste if the Clipboard is empty or if the
selected text cannot be replaced.

You can cut, copy, and paste text from the editing window, another comment, the
text currently displayed in the Comment editor or another Windows application.

Inserting Comments
You insert or edit comment lines using the Comment editor.  Once you are in the
Comment editor you can write multiple comment lines for a step and enter them.
The Comment editor automatically places the leading semicolons, required by
the Quickstep editor, and a space before any text.

To insert a comment:

1. Highlight a <<Comment Line>> placeholder using one of the following
methods:

• Highlight <<Comment Line>> and double click the mouse to activate
the Comment editor.

• Highlight <<Comment Line>> and press Enter to activate the Com-
ment editor.

The Comment Editor window appears.

2. Type the text of the comment.  The editor adds the semicolons and a space
before the text when it enters the comment in the step.

REMEMBER: The maximum line length is 255 characters.

Entering Comments
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3. To insert the comment in the step, select Exit Saving Changes from the File
menu.

The Quickstep editor enters the comment in the step.
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Entering an Immediate Action Selection
The possible output changes are: turn all outputs off, no change in the current
state of the outputs, or turn specific output(s) on or off.  To enter an output
change using an immediate action selection:

1. Place the mouse pointer on the <<Output Change>>  placeholder and do
one of the following:

• Double click the left mouse button.

• Select the placeholder with the mouse pointer and press Enter.

The editor displays the types of output changes in the Selection bar.

2. Select the output change using the mouse or keyboard.

The editor enters the output change in the step.

Entering an Output Change for a Specific Output
To enter an output change

1. Place the mouse pointer on the <<Output Change>>  placeholder and do
one of the following:

• Double click the left mouse button.

• Select the placeholder with the mouse pointer and press Enter.

Specifying Output Changes
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The editor displays the types of output changes in the Selection bar.

2. Select Output Name using the mouse or keyboard.

The list or symbolic names for outputs appears.

3. Select the symbolic name for the output using the mouse or keyboard.

The editor enters the output change in the step.
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Programming Quickstep Instructions
When programming instructions, you follow these general steps:

1. Select the <<Statements>> place holder to display the list of Quickstep
instructions in the Selection Bar.

2. Select the instruction you want to program.

3. When the Selection bar lists the possible parameters for the instruction (this
includes symbol names), choose the appropriate selection.

As you program an instruction, your choices appear in the Selection bar and
the placeholder for the next parameter appears in the Editing window.

4. Continue selecting each placeholder to list the possible parameters for the
instruction in the Selection bar until you are finished programming the
instruction.

Use one of the following methods to list items in, or select items from, the
Selection bar

• Double click on the item with the mouse pointer.

• Select the item with the mouse pointer and press Enter.

• Press the Tab key to move the focus to the list of options displayed in the
Selection bar.  Use the Arrow keys to highlight the item and press Enter.

• Type the name of the item.  Once you have entered enough letters to
uniquely identify the item, it appears in the Selection box.  Press Enter.

The following sections show how to program instructions using PROFILE SERVO
and MONITOR BOOLEAN instructions as examples. This section also shows how to
define a symbolic name in the process of programming an instruction.

Programming Instructions and Parameters
This example shows how to use the selection bar to program an instruction.

1. Highlight a <<Statements>> placeholder with the mouse pointer and do one
of the following:

• Double click the left mouse button.
• Press Enter.
The list of Quickstep instructions appears in the Selection bar.

2. Select the instruction, in this example Profile, using one of the following
methods:

• Select Profile with the mouse pointer and double click the mouse.
• Type P from the keyboard to select Profile and press Enter.
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The list of  profile instructions appears in the Selection bar and the
placeholder <<Profile What>> appears in the Editing window.

3. Select Profile Servo and insert it in the statement using the mouse or
keyboard.

The placeholder <Servo Name> is highlighted in the Editing window and
the Selection bar lists the symbolic names of all the servos.

4. Select the servo name using the mouse or keyboard as before.

NOTE: You can also define a new servo name at this time, see Defining Symbolic Names When
Programming an Instruction in this chapter.

The Quickstep editor inserts the servo name into the instruction.

The Quickstep editor continues to highlight each placeholder until you have
filled in the parameters for the instruction.
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Programming Quickstep Instructions

Entering Numeric Constants Defined as Symbolic Names
Any numeric constant can be given a symbolic name and used in your Quickstep
program.  The Selection bar lists numeric values defined as symbolic names as
Data Sources.  This example shows the <<Numeric Source>> placeholder for
the servo’s maxspeed.

1. Place the mouse pointer on the <<Servo Maxspeed>> placeholder and do
one of the following:

• Double click the left mouse button.
• Select the placeholder with the mouse pointer and press Enter.

The placeholder <<Numeric Source>> appears in the Editing window and
the Selection bar lists the types of Numeric Sources.  There are three
choices; one choice, Data Sources, includes symbolic names.

2. Select Data Sources to list the symbolic names.

3. Select the appropriate symbolic name using the mouse or keyboard as
before.

In this example, maxspeed=X_Y_home_maxsp appears in the Editing
window.
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Entering Numeric Constants From the Keyboard
You can also enter numeric constants by typing the number from the keyboard.
This example enters the proportional parameter (Servo P) in a Profile Servo
instruction.

1. Place the mouse pointer on the <<Servo P>> placeholder and do one of the
following:

• Double click the left mouse button.
• Select the placeholder with the mouse pointer and press Enter.

The placeholder <<Numeric Source>> appears in the Editing window and
the Selection bar lists the types of Numeric Sources.

2. Select Number using  the mouse or keyboard.

The Selection box is empty.

3. Type a number and press Enter.

P=2 appears in the Editing window.
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Programming Quickstep Instructions

Programming Boolean Monitor Instructions
Monitor instructions allow the controller to check the state of inputs, flags,
motors, and servos.  A Boolean Monitor instruction can check the state of more
than one controller resource and specialized I/O or motion control device.

To program a Boolean Monitor instruction:

1. Select Monitor from the list of instructions in the Selection bar, using  the
mouse or keyboard.

The placeholder <<Monitor What>> appears in the Editing window and the
Selection bar lists choices for monitor.

2. Select Boolean using the mouse or keyboard as before.

The placeholder <<Monitor Operator>> appears in the Editing window
and the Selection bar lists the Boolean operators.

3. Select the Boolean operator you want.  This example uses Or.

The placeholder <<Monitor What>> appears in the Editing window and the
Selection bar lists choices for monitor.

4. Select the controller resource or device you want using the mouse or key-
board as before.

The Selection bar lists the symbolic names for the resource type you chose.
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5. Select the symbolic name you want.

NOTE: You can also define a new servo name at this time, see Defining Symbolic Names When
Programming an Instruction in this chapter.

6. Continue choosing controller resources or devices until you complete the
Monitor instruction.

7. When you are finished with your Boolean expression, select the <<Destina-
tion>> placeholder and specify the destination.

The Quickstep editor inserts the destination step.

8. When you select the next placeholder, the editor deletes any unused place-
holders in the monitor instruction.
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Programming Quickstep Instructions

Defining Symbolic Names When Programming an Instruction
You may need to define a symbol when you are partially through entering an
instruction.  You can define new symbolic names from the Selection bar.  Sym-
bolic names defined using this method are automatically entered in the Symbol
Table.

To define a symbolic name from the Selection bar:

1. Type the new symbol name in the Selection box and Press Enter.

The editor displays the Define New Symbol dialog box.  The symbolic name
and type appear in the Name and Type fields.

2. Edit the symbolic name, if necessary.

3. Press Tab to go to the Number field.

4. Type the Number of the controller resource (flag number 1 here) in the
Number field.
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5. Select OK to enter the symbolic name in the instruction.
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Inserting New Lines and Steps
As you write your Quickstep program you will need to insert:

• New steps
• New output change placeholders
• Comment line placeholders
• Statement placeholders.

You can insert new steps before or after the current step, and the editor numbers
or renumbers the steps accordingly.

You can also insert new comment lines (<<Comment Line>>), output changes
(<<Output Change>>), and instructions (<<Statements>>) before or after the
current line.  Depending on the location of the cursor, the Quickstep editor
displays different options.  For example, when the highlight is on a comment
line, the selections in the edit and shortcut menus appear as follows:

Line Menu

Shortcut Menu

When the highlight is on an instruction line, the selections in the Edit or
Shortcut menu appear as follows:

Line Menu
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Shortcut Menu

You can also insert a new statement placeholder before any other instructions in
a step by selecting New First Statement from the Edit or Shortcut menus.

Inserting New Steps
The following example inserts a new step after the current step.  You can also
insert a new step before the current step.  In either case, the editor numbers or
renumbers the steps.

To insert a new step:

1. Highlight an item in the current step with the mouse pointer.

2. Do one of the following

• Select Steps from the Edit menu and choose Insert Step Before or
Insert Step After.

• Select Insert Step Before or Insert Step After from the Shortcut menu

• Select the New Step icon on the Toolbar to insert a new step after the
current step.
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In this example, the editor inserts a new step after the current step.

Inserting New Lines
You can insert new comment, output change, and Statement placeholder before
or after the current line.

The following example inserts a new statement after the current line.

1. Highlight an item on the line above with the mouse pointer.

2. Do one of the following:

• Select Lines from the Edit menu and choose the Insert Before or
Insert After option you want.

• Select the Insert Before or Insert After icons on the Toolbar with the
mouse pointer.

• Select the Insert Before or Insert After option from the Shortcut
menu.

REMEMBER! The selections on the Edit and Shortcut menus change depending on the location of the
cursor.

The editor inserts a new placeholder after the current line.

Inserting New Lines and Steps
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Inserting an Output Change
The following example inserts a new placeholder for an output change.

1. Highlight an item on the line with the mouse pointer.

2. Do one of the following:

• Select Lines from the Edit menu and choose the insert option you want.

• Select the Insert Before or Insert After icon on the Toolbar with the
mouse pointer.

• Select the insert option you want from the Shortcut menu.

REMEMBER! The selections on the Edit and Shortcut menus change depending on the location of the
cursor.

The editor inserts an output change placeholder above the current line.

Inserting a New First Statement Placeholder
New First Statement inserts a new <<Statements>> placeholder before any other
instructions or statement placeholders in a step.  It also inserts a new <<State-
ments>> placeholder in a step that has had all its instructions or statement
placeholders deleted.

To insert a new first statement:

1. Highlight any step name, comment, output change, statement placeholder, or
instruction in a step.
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2. Do one of the following:

• Select Lines from the Edit menu and choose the New First Statement
option.

• Select the New First Statement option from the Shortcut menu.
The editor places a new statement placeholder as the first statement in the
step.

Inserting New Lines and Steps
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Cutting, Copying and Pasting Lines and Steps
The Importance of the Current Field when Cutting, Copying and Pasting

The Quickstep program, as it appears in the Quickstep editor window, is com-
posed of a number of fields (software professionals them “tokens”).  For ex-
ample, the instruction–monitor partsensor goto next–actually
consists of four fields:

• The instruction name: monitor
• The input name: partsensor
• The instruction token: goto
• The destination of the instruction: next

As you work in the Quickstep editor window, you may move a cursor from one
field to another by using the arrow keys on your computer. The field, or token, to
which you have moved the cursor is known as the “current field.”  The current
field is indicated by displaying the field in a unique color scheme.  You can
modify how the current field cursor is displayed by changing its colors, so that it
may be displayed in any color you choose.  For information on changing the
colors of fields, see Changing Editor Field Colors in Chapter 3, Quickstep
Editor Basics.

If you Paste text from the clipboard to the current field, the Quickstep editor will
attempt to deduce whether the pasted text should be placed before or after the
field, based on a series of rules.

If, however, you wish to replace one or more fields with text from the clipboard,
you must “select” the field by dragging the mouse pointer across it, similar to
selecting text in word processor applications.  Then, pasting text will cause the
new text to replace the selected field.

Similarly, you cannot use the copy or cut commands on the current field without
first selecting it by dragging the mouse across it.

Cutting Text
Cut removes selected text or lines of text and places it on the clipboard.  The
text placed on the Clipboard replaces the previous contents and remains there
until you replace it with a new item.

When you cut a step header (number and name) the Quickstep editor cuts the
entire step.

Cut text by choosing:

• Cut from the Edit menu (shortcut, type CTRL + X).
• Cut icon on the Toolbar

Copying Text
Copy copies selected text to the Clipboard.  Any text that you copy to the
Clipboard replaces the previous contents and remains there until you replace it
with a new item.

When you copy a step header (number and name) the Quickstep editor copies
the entire step.
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Copy text by choosing:

• Copy from the Edit menu (shortcut, type CTRL + C).
• Copy icon on the Toolbar

Pasting Text
Paste and Paste After insert a copy of the Clipboard contents in your program.
You cannot use paste if the Clipboard is empty or if the text cannot be replaced
or pasted.

The Quickstep editor has the following rules for pasting:

• When you have selected a field, a line or a step with the mouse pointer,
Paste replaces it.

• When you do not select anything with the mouse, Paste inserts the text, line,
or step in the adjacent syntactically correct location to the current field.

• When you do not select anything with the mouse and are pasting text that
can be placed either before or after the current field, then Paste inserts the
text, line, or step before the current field and Paste After inserts it after the
current field.

• The Quickstep editor does not paste a step in the middle of an existing step
or an instruction in the middle of an existing instruction.

Paste text by choosing:

• Paste from the Edit menu (shortcut, type CTRL + V).
• Paste icon on the Toolbar

Paste text after the highlight by selecting Paste After from the Edit menu.

Copying and Pasting Text from one Program to Another
Cut, copy and paste work by copying and pasting text to and from the Clipboard.
Symbolic names in pasted text are interpreted in the context of the program you
paste them into.  Pasting text from one Quickstep program to another can result
in three types of errors:

1. The symbolic name is not defined in the destination program.  This causes
an error message, and the editor flags the pasted text as unparsed source.

To correct this error, define the new symbol name and select Check Syntax
from the Edit menu to recheck the line.

2. The symbolic name(s) have a different definition in the destination program
than in the orginally program.  For example, the name may refer to a flag in
the original program and to a servo in the destination program  The symbolic
name no longer makes sense in the new context.  This causes and error
message and the editor flags the pasted text as unparsed source.
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To correct this error, you can do one of the following:

• Define a new symbol name and use the Line editor to correct the symbol
name.

• Use the Line editor to change the symbol name to different name.
3. The symbolic name has a different, but syntactically valid definition, in the

destination program.  This causes an error that is not detected.

NOTE: The best way to avoid copy and paste problems is to define a standard set of symbolic names
for use in related Quickstep programs and import them into each program as it is created.

Cutting, Copying and Pasting Lines and Steps
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Deleting Lines and Text
Deleting Items

You can delete a portion of the text in a comment or instruction.  The Delete,
Delete Line, Delete Step functions permanently delete the selected text.  De-
leted items cannot be replaced or pasted.  The wording of the delete function
changes depending on the location of the cursor.

You can delete an entire line or step by highlighting the line or group of lines
and selecting Delete.

The Quickstep editor has the folowing restrictions:

• Deleting a step name or number deletes the entire step
• Deleting the first word in an instruction deletes the entire instruction

WARNING! Do not delete all the steps in a program.  This causes a General Protection Fault.

To delete text or other items:

1. Highlight the text you want to delete with the mouse pointer.

2. Select Delete from the Edit or Shortcut menu.

The editor deletes the text.

Deleting an Entire Line
You can delete an entire comment, output change or instruction line.  The Delete
Line function permanently deletes the highlighted or selected lines.  Deleted
items cannot be replaced or pasted.  The wording of the delete function changes
depending on the location of the cursor.

To delete lines:

1. Highlight a portion of the line you want to delete with the mouse pointer.
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2. Do one of the following:

• Select Lines from the Edit menu and then the Delete option.
• Select the Delete option from the Shortcut menu
The editor deletes the line.

Deleting Lines and Text
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Changing Step Names
Using the Quickstep editor you can change the name of a step.  The editor
automatically goes through your program and changes every reference of the
step to the new step name.  The editor does not allow you to change the step
name to the name of an existing step.

To change a step name:

1. Place the mouse pointer over the step name and do one of the following:

• Double click the left mouse button.
• Highlight the step name and press Enter.

The Selection bar lists the options to change the step name or step number

2. Select =>Step Name using the mouse pointer or keyboard.

3. Type the new step name.

It appears in the Selection bar.

4. Press Enter to change the step name.

The editor changes the step name and all the references to it.

Changing Step Numbers
Using the Quickstep editor you can change step numbers.  When necessary, the
editor automatically goes through your program and changes the numbers of the
steps below it.  When you change a step number to the number of an existing
step, the editor renumbers the steps.

NOTE: The editor does not permit you to change a step number to a number lower than the
preceeding step.

Changing Step Names and Numbers
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To change a step number:

1. Place the mouse pointer over the step number and do one of the following:

• Double click the left mouse button.
• Highlight the step number and press Enter.

The Selection bar lists the options to change the step name or step number.

2. Select =>Step Number using the mouse or keyboard.

3. Type the new step number.

It appears in the Selection bar.

4. Press Enter to change the step number.

The editor changes the step number and the number of subsequent steps.

Changing Step Names and Numbers
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Editing Comments
You can edit comment lines with the Comment editor.  The Comment editor
automatically places the leading semi-colons and a space before any text.

To edit a comment:

1. Place the mouse pointer on the comment line and do one of the following:

• Double click the left mouse button to activate the Comment editor.
• Highlight the comment and press Enter to activate the Comment editor.
The Comment Editor window appears

2. Edit the comment.  You can use the cut, paste, and copy commands.

REMEMBER: The maximum line length is 255 characters.

3. To insert the comment in the step, select Exit Saving Changes from the File
menu.

The Quickstep editor enters the comment in the step.
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Using Replace with Alternate
Replace with Alternate allows you to replace an output change or a selected
portion of an instruction with a different choice.  When you select Replace with
Alternate, the editor lists the alternate choices in the Selection bar.

When replacing part of an instruction, depending on the instruction and the part
of the instruction you choose, the Selection bar choices change.

NOTE: Selecting Replace with Alternate when the highlight is on an instruction line containing
unparsed source, activates the Line editor.

Replacing Part of an Instruction
To replace with an alternate:

1. Place the mouse pointer over the portion of the instruction you want to
replace and do one of the following:

• Highlight the selection and choose Replace with Alternate from the
Edit or Shortcut Menu.

• Highlight the selection and press Enter.
The Editor lists the alternate choices in the Selection bar.

2. To replace the selection, use the mouse or keyboard to select your choice

The Editor replaces the selected text with the alternate.

4. Continue programming the instruction.
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Replacing an Output Change
You can replace an output change using Replace with Alternate.

1. Place the mouse pointer over the output change you want to replace and do
one of the following:

• Double click the left mouse button.
• Highlight the output change and choose Replace with Alternate from

the Edit or Shortcut Menus.

The Editor lists the alternate choices in the Selection bar.

2. To replace the selection, use the mouse of keyboard to select your choice.

If you select All Off or No Changes, the editor enters the choice in the step
and deletes any other output changes in the step.  If you select Output
Name, the editor lists the symbolic names for the outputs in the Selection
bar.

4. If you are turning an output on or off, select the symbolic name for the
output you want using the mouse of keyboard.

The editor enters your selection in the output change line.
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Using the Line Editor
The Line Editor

The Line editor window appears when you select Edit Line Text from the
Shortcut or Edit menus.  Using the Line editor, you can edit a single output
change or an instruction.  If you type additional lines, the Line editor ignores
them.

Line Editor Menus
The menu bar contains the File, Edit and Help menus.  Using these menus you
can enter edited text into your Quickstep program, cut, copy and paste text in the
Line editor; and display the Help file for the Line editor.

Selecting File displays the following menu:

• Exit Saving Changes: enters the edited line.

• Exit Discarding Changes: exits the Line editor without changing the
existing instruction or output change.

Selecting Edit displays the following menu:

• Cut: removes selected text and places it on the clipboard.

• Copy: copies selected text to the Clipboard.

• Paste: inserts a copy of the Clipboard contents at the insertion point.  If you
have highlighted any text, the editor replaces the selection with the text on
the Clipboard. You cannot use paste if the Clipboard is empty or if the
selected text cannot be replaced.

NOTE: Selecting Replace with Alternate when the highlight is on an instruction line containing
unparsed source, activates the Line editor.

Editing Output Change and Instruction Line Text
You can edit an output change or instruction using the Line editor.  The Line
editor only edits one line at a time.  If you type additional lines, the editor does
not enter them in the program.

To edit an instruction line:

1. Open the editor using one of the following methods:
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• Highlight a parameter in the instruction and select Edit Line Text from
the Shortcut menu.

• Highlight a parameter in the instruction and select Edit Line Text from
Lines on the Edit menu.

The Line Editor window appears

2. Edit the instruction.  You can use the cut, paste, copy commands.

3. To insert the edited instruction in the step, select Exit Saving Changes from
the File menu.

The Quickstep editor checks the line syntax and enters the instruction in the
step.
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As you program steps, and their component instructions, output changes, and
comments, the Quickstep editor displays empty placeholders.  In most cases, the
editor deletes optional placeholders, but sometimes you must delete them
yourself.

To delete all the unused placeholders in a program:

Select Remove Placeholders from the Edit menu.

The following is a list of placeholders that you may want to delete when the
editor does not:

• Optional place holders have a cyan background and black lettering (default).
They can be removed if you are not using them.

• Comment placeholders can be removed if the step does not have comments.

• Extra output change placeholders can be removed.  However, you must
specify no change, all off, or an output change at the beginning of each step.

• Extra Statement placeholders can be removed.

Removing Placeholders
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The Quickstep editor displays lines with errors in red (default).  A paste
operation can create unchecked lines, and converting an 1.6 or 1.7 Quickstep
program can cause lines to be displayed as errors when they do not have any.

To make the editor check the syntax of these lines, choose Check Line
Syntax from the Edit menu.

Searching for Syntax Errors
To search for lines with an error or unchecked syntax, choose Find Next
Error from the Search menu.

To find an error or unchecked syntax in a previous step, choose Find
Previous Error from the Search menu.

Checking Syntax
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Using Search and Goto
Searching for a Step

Goto searches a Quickstep program for a specific step.  The Quickstep editor
can search forward or backward for the step, depending where you start the
search.

NOTE: Goto is the name of a search function in the Quickstep editor.  GOTO is also an instruction in the
Quickstep programming language.  For information on using the GOTO instruction, see the
QuickstepTM Langauge and Programming Guide.

You can use Goto to search for a step in two different ways:

Method One
1. Highlight the step name you want to find.

2. Search for the step name using one of the following methods:

• Choose Goto Step from the Search menu.
• Choose Goto Step from the Shortcut menu.
• Select the Goto icon on the Toolbar.

The editor finds the step.

Method Two
1. Do one of the following:

• Choose Goto Step from the Search menu.
• Choose Goto Step from the Shortcut menu.
• Select the Goto icon on the Toolbar.

The list of step names appears in the Selection bar.
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2. Use the mouse of keyboard to select the name of the step you want to find

The editor finds the step.

Searching for Symbolic Names
Find Symbol searches a Quickstep program for a specific symbolic name.  The
Quickstep editor begins the search from the location of the cursor.  If you are at
the end of a program file you should go to the beginning before starting your
search.  After the editor has found the first occurrence of a symbolic name, you
can use Find Next.  Find Next finds the next occurrence of the symbolic name
specified by Find Symbol.

To search for a symbolic name:

1. Choose Find Symbol from the Search menu.

The editor displays the symbolic names in the Selection bar.



5-18 QuickstepTM User Guide
Control Technology Corporation proprietary. Reproduction or distribution forbidden.

2. Select the symbolic name you want to find.

3. Press Enter.

The editor finds the symbolic name.

NOTE: If you double click on the symbolic name with the mouse pointer, you can skip step 3.

4. To find the next occurrence of the symbolic name, do one of the following:

• Choose Find Next from the Search menu.
• Choose the Find Next icon on the Toolbar.

The editor finds the next occurrence of the symbolic name.
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Screen Overview
When you start the Quickstep editor, it automatically activates the Symbol
Browser.  Use the Symbol Browser to specify step names and symbolic
names for the following controller resources and specialized I/O and motion
control devices:

• Analog inputs
• Analog outputs
• Counters
• Data Table columns
• Displays
• Flags
• Inputs
• Outputs
• Stepping motors
• Servo motors
• Numeric registers
• Thumbwheels

You can also give symbolic names to numeric constants used in the program.

You can edit the symbolic names that appear in the list of symbolic names,
using the copy, cut, paste and delete options on the Edit menu and Toolbar.
To move from one field to another on the list of symbolic names and list of
symbol types, use the arrow keys

Symbol Browser Overview

List of symbolic names. Only the symbolic
names for the selected symbol type appear.

List of symbol types

Title Bar

Menu bar - Contains the File,
Edit, Options and Help menus

Toolbar - Gives you quick
mouse access to many tools
used in the Symbol Browser
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The Toolbar
The Toolbar appears across the top of the Symbol Browser window and gives
you quick mouse access to many tools used in the Symbol Browser.

Open - Opens an existing Symbol Table.  Accessible only when
using the Symbol Browser as a standalone editor.

Save - Saves the current Symbol Table with its current name.
Accessible only when using the Symbol Browser as a standalone
editor.

Copy - Copies the selected text and places it on the Clipboard

Paste - Inserts the contents of the Clipboard at the insertion point

New Symbol - Displays the Define Symbol dialog Box.

Sort Key - Toggles from N to V and displays the list of symbolic
names in alphabetic order or by their value.

Sort Order - Toggles from é to ê and displays the list of symbolic
names in ascending or descending order of value.

Find Step - Tells the Quickstep editor to find the step whose name
you’ve highlighted

Find Reference - Tells the Quickstep editor to find the first refer-
ence to the symbolic name you’ve highlighted

About - displays the version number and the copyright notice.
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Changing Column Size
You can adjust the size of the columns in the list of symbolic names by moving
the column dividers.

To change the column size:

1. Place the mouse pointer on the column divider line.

2. When the double arrowhead symbol appears, press the mouse button and
move the column divider.

3. Release the mouse button when the column divider is in the correct location.

Re-displaying Columns
It is possible to move the column divider so far that the column disappears.
When this happens, re-display the column by selecting:

• Show Name from the Options menu to re-display the name field.

• Show Value from the Options menu to re-display the value field.

• Show Transition from the Options menu to re-display the output transition
field.

• Show State from the Options menu to re-display the input state field.

Symbol Browser Overview
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Changing the Font
The Symbol Browser displays text in Microsoft Sans Serif font.  You can change
the default font using the Font dialog box.

1. Select Font from the Options menu.

The Fonts dialog box appears.

2. Select the Font, Font Style, Size, and Color.

The Sample box displays the current font.

NOTE: We do not recommend selecting the Strikeout or Underline effects.

3. Select OK to apply your changes.

To exit without saving your changes, select Cancel.

Specifying the Order of Symbolic Names
The Toolbar contains two icons that control how the Symbol Browser displays
the list of symbolic names.  One icon toggles to display the list by name (N) or
value (V), and the other icon toggles to display the list in ascending (�) or
descending (�) order of value.

Listing by Name or Value
Using the toggle icon on the Toolbar, you can display the list of symbolic names
in alphabetic order by name or in order of value.

Change the way in which symbolic names are listed by selecting:

• The N or V icon on the Toolbar.

   Lists the symbolic names in alphabetic order by name.

   Lists the symbolic names in order by value
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• Sort by Value from the Options menu

A check mark next to Sort by Value indicates that the list is sorted in order
of value.  No check mark indicates that the list is sorted in alphabetic order
by name.

Examples of Sorted Lists
• A list ordered by name appears as follows:

• A list ordered by value appears as follows:

Listing in Ascending or Descending Order
Using the toggle icon on the Toolbar, you can display the list of symbolic names
in ascending or descending order of value.  To change the way in which sym-
bolic names are listed select:

• The up or down arrow icon on the Toolbar.

   Lists the symbolic names in ascending order of value.

   Lists the symbolic names in descending order of value.
• Sort by Ascending from the Options menu

A check mark next to Sort by Ascending indicates that the list is sorted in
ascending order.  No check mark indicates that the list is sorted in
descending order of value.

Examples of Sorted Lists
• A list ordered by value in ascending order appears as follows:

Symbol Browser Overview
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• A list ordered by value in descending order appears as follows:

• A list ordered by name and ascending order appears as follows:

• A list ordered by name and descending order appears as follows:

Inserting an Existing Symbol Table
You can insert an existing table from another Quickstep program in your current
Symbol Table.  This allows you to use the same symbolic names for more than
one program without having to redefine them.

1. Bring up the Quickstep editor and define the parameters for your Quickstep
program.

2. Click the Symbol Browser icon to display the Symbol Browser.

3. Select Insert from the File menu.

The Load Symbol Table dialog box appears.

4. If the Symbol Table is in a different directory, select the appropriate direc-
tory.
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5. Select the name of the Symbol Table you wish to load.

6. Select OK.

Saving a Symbol Table
The Quickstep editor automatically saves the Symbol Table when it saves your
Quickstep program, using the same name you specified for your Quickstep
program.

When using the Symbol Browser in conjunction with the Quickstep editor the
Save options on the File menu and Toolbar are grayed out.

We recommend saving your Quickstep program several times during an editing
session.

NOTE: When using the Symbol Browser as a standalone editor, you must save your Symbol Table
using the Save options on the File menu or on the Toolbar.

Symbol Browser Overview
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Defining Symbolic Names
Using the Symbol Browser, you can create symbolic names for the following
types of symbols:

• Controller resources, such as flags or registers
• I/O devices, such as numeric displays
• Motion control devices, such as servos
• Undefined steps
• Numeric constants

Symbolic names are entered using the Define Symbol dialog box.

IMPORTANT! Each symbolic name must be unique, and within a symbol type (e.g., servos, registers)
each numeric must be unique.  This means you can only have one symbolic name for
register 10.  Inputs and outputs each have two possible states, and each state can be
given a unique symbol name.

An exception to this rule is numeric constants.  You can have two numeric
constants one called Over_Pressure with a value of 5000 and another called
Base_Velocity with a value of 5000.

Entering Symbolic Names
To define symbolic names:

1. Display the Define Symbol dialog box using one of the following methods:

• Selecting New Symbol from the Edit menu (shortcut, type
CTRL + N).

• Selecting the Define Symbol icon on the Toolbar.

The Define Symbol dialog box appears.

2. Type the symbolic name in the Name field.  This example uses flags.

3. Press Tab to go to the next field.
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4. Click the arrow on the right side of the Type field to display a list of symbol
types

5. Select the symbol type by clicking it with the mouse pointer.

The Type field displays the symbol type.

NOTE: If the symbol type is already displayed, you can skip steps 4 and 5.

6. Press Tab to go to the next field.

7. Type the number of the flag in the Number field.

8. Do one of the following:

• Select OK to display the symbolic name in the list and to close the
Define Symbol dialog box.

• Select Apply to display the symbolic name in the list and keep the
Define Symbol dialog box open.

Defining Symbolic Names



Using the Symbol Browser 6-11

Control Technology Corporation proprietary. Reproduction or distribution forbidden.

The new symbol name appears in the list.

Specifying Step Names
You can create symbolic names for steps.  These symbolic names must be
created using the symbol type Undefined Steps.  Once an undefined step name is
used in a Quickstep program, the Symbol Browser automatically changes the
symbol type definition from Undefined Step to Step.

When you enter a step name for an undefined step, you cannot give it a value for
a step number.  The value field is zero until you use it in your Quickstep pro-
gram.

To specify undefined step names:

1. Display the Define Symbol dialog box using one of the following methods:

• Selecting New Symbol from the Edit menu (shortcut, type
CTRL + N).

• Selecting the Define Symbol icon on the Toolbar.

The Define Symbol dialog box appears.

2. Type the undefined step name in the Name field.

3. Press Tab to go to the next field.
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4. Click the arrow on the right side of the Type field to display a list of symbol
types

5. Select Undefined Step by clicking it with the mouse pointer.

The Type field displays the symbol type.

NOTE: If the correct symbol type is already displayed, you can skip steps 3 through 5.

6. Do one of the following:

• Select Ok to display the symbolic name in the list and to close the
Define Symbol dialog box.

• Select Apply to display the symbolic name in the list and keep the
Define Symbol dialog box open.

Specifying Symbolic Names for Inputs
Inputs can have two symbolic names for the same input.  One symbolic name is
for monitoring the input as a normally open input.  This means the input’s active
state is closed. The other possible symbolic name refers to the same input as a
normally closed input.  In this case, the input is considered active when the input
is open.  Refer to the Quickstep Language and Programming Guide for a de-
scription of normally open and normally closed inputs.

Defining Symbolic Names
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The Define Symbol dialog box has an extra field labeled Normal.  Use this field
to specify normally open or closed for inputs.

The list of symbolic names has three columns (shown below):

• Symbolic name
• Value (number of the input)
• Normal state of the input

Specifying Symbolic Names for Outputs
Outputs can have two symbolic names for the same value.  One symbolic name
turns the output on, and the other turns it off.  The Define Symbol dialog box has
an extra field labeled Turn to enter this information

The list of symbolic names has three columns (shown below):

• Symbolic name
• Value (number of the output)
• Output transition (output on or off)
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Editing Symbol Browser Entries
Editing Symbolic Names

You edit a name in the list of symbolic names by selecting the field and entering
the new name.

To edit a symbolic name:

1. Place the cursor in the appropriate field by selecting it with the mouse
pointer or by using the Tab and Arrow keys.

2. Type or paste the new name and press Enter.

3. To edit a value in another field, you can use the Arrow keys to move the
field.

Deleting Symbolic Names
You can delete a name in the list of symbolic names by selecting the field and
deleting it.  This deletes the both the symbolic name and its associated value.  If
you try to cut a symbol name that is used in your Quickstep program, the Sym-
bol Browser displays a message stating that the symbol is used in the program.
You must first delete all references to the symbolic name before you can delete
it.  If you are using the Symbol Browser as a standalone editor, the message does
not appear.

To delete a symbolic name and its associated value:

1. Place the cursor in the appropriate field by selecting it with the mouse
pointer or by using the Tab and Arrow keys.

2. Select Delete from the File menu (Shortcut, press the Delete key).

The Symbol Browser deletes the entry.
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Copying and Pasting Text
You can copy and paste text in the Symbol Browser.

Copying Text
Copy copies selected text to the Clipboard. This command is available only
when you select text.

Copy text by selecting:

• Copy from the Edit menu (shortcut, type CTRL + C).
• Copy icon on the Toolbar

Pasting Text
Paste inserts a copy of the Clipboard contents at the insertion point.  If you have
highlighted text, Paste replaces it.  You cannot use paste if the Clipboard is
empty or if the selected text cannot be replaced.

Paste text by selecting:

• Paste from the Edit menu (shortcut, type CTRL + V).
• Paste icon on the Toolbar
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You can print a Symbol Table:

1. Select Print from the File menu.

2. When the Print dialog box appears, choose the options you want.

3. Select Ok to print the Symbol Table.

Printing a Symbol Table
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Finding a Step in a Quickstep Program
Find Step finds the selected step name in your Quickstep program.  This func-
tion does not work when the Symbol Browser is in Standalone mode.

To find a step in your Quickstep program:

1. Highlight a step name in the list of symbolic names.

2. Click the Find Step icon with the mouse pointer.

The Quickstep editor finds the step.

Finding the First Occurance of a Symbolic Name
Find First Reference finds the first reference to a symbolic name in your Quick-
step program.  This function does not work when the Symbol Browser is in
Standalone mode.

To find a step in your Quickstep program:

1. Highlight a symbol name in the list of symbolic names.

Finding Steps and Symbols in a Quickstep Program
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2. Click the Find First Reference icon with the mouse pointer.

The Quickstep editor finds the first occurance of the symbolic name.

Finding Steps and Symbols in a Quickstep Program
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In some cases you may want to specify the symbolic names before activating the
Quickstep editor.  To do this you must use the Symbol Browser as a standalone
editor.

The steps for creating a Symbol Table using the Symbol Browser as a standalone
editor are as follows:

• Activate the Symbol Browser

• Enter the symbolic names

• Save the Symbol Table using a different name than Quickstep program you
are planning to write.

Activating the Symbol Browser and Opening a Symbol Table
1. To activate the Symbol Browser, chose one of the following methods:

• Using the File Manager:

a. Open the File Manager and select the directory where the Quickstep
2.0 files are stored.  The default directory is C:\QSWIN.

b. Place the mouse pointer over the file labeled browser.exe, and
double click the left mouse button.

• Using the Program Manager:

a. Following the instructions provided with Microsoft Windows, create
an icon for Symbol Browser in the Quickstep group in the Program
Manager.

b. Activate the Symbol Browser by selecting the icon as you would any
Microsoft Windows program icon.

The Load Symbol Table dialog box appears.

2. To open a Symbol Table, chose one of the following methods:

• To create a new Symbol Table, select Cancel on the Load Symbol Table
dialog box to display the Symbol Browser.

• To open an existing Symbol Table, choose the name of the Symbol Table
you wish to load and select OK.  If the Symbol Table is in a different
directory, select the appropriate directory.

Using the Symbol Browser as a Standalone Editor
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Saving Symbol Tables
Once you have defined your symbolic names you must save your Symbol Table.
The table must have a different name than the Quickstep program you are
planning to write.  When the Quickstep Programming Editor creates a new
program file, it overwrites any Symbol Table with the same name as the program
file.

Saving a New Symbol Table
1. Do one of the following:

• Select Save as from the File menu.

• Select the Save icon on the Toolbar.

The Save Symbol Table dialog box appears:

2. Enter a name for the new table.

REMEMBER! The table must have a different name than the Quickstep program you are planning to
write.

3. If you want to save the Symbol Table in a different directory, select the
appropriate directory.

4. Select OK.

Saving an Existing Symbol Table
Do one of the following:

• Select Save from the File menu (shortcut, type CTRL + S).

• Select the Save icon on the Toolbar.

Exiting the Symbol Browser
When using the Symbol Browser as a standalone editor, you must exit it before
you start the Quickstep editor.  The editor will then reactivate the Symbol
Browser.  The only time you should exit the Symbol Browser is when you are
using it as a standalone editor.

Using the Symbol Browser as a Standalone Editor
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To exit a standalone Symbol Browser:

1. Select Exit from the File menu.

If you have not saved your most recent changes the following dialog box
appears:

2. Select the appropriate choice.
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The Data Table editor allows you to enter the information in a Data Table.  The
Data Table stores numeric information and messages used in Quickstep pro-
grams.  It can contain greater than 8000 numbers in an array, depending on the
controller model.  The numbers can range from 0 to 65,535.

You specify the number of rows and columns in a table using the Parameter
editor.  You activate the Data Table editor from Quickstep editor by selecting the
Data Table option from the View menu.

You can use the copy, cut, paste and delete options on the Edit menu to edit the
values or messages that appear in the table.

You can also use the arrow keys to move from one cell to another on the list of
values or messages.

Data Table Editor Screen Overview
The Data Table editor menu is shown below and has the following parts:

The Toolbar
The Toolbar appears across the top of the Data Table editor window, below the
menu bar.  It contains the following tools:

Data Table Editor Overview

Menu bar - Contains the File, Edit,
Options, and Help menus.
Toolbar - Gives you quick mouse
access to many tools used in the
Data Table editor.

Title bar

Table Rows and Columns -
Displays the rows and columns in
your Data Table.  The Data Table
is a two-dimensional array of
numbers  The contents of table
will be stored in the controller’s
memory along with your
Quickstep program.

Message List - This
list displays the
ASCII character
epresentation of the
data in each row of
the table. You can
uses this area to
create message for
transmission to
external devices
such as, alpha-
numeric displays or
bar code readers.
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Open Existing File - Opens an existing Data Table. Accessible
only when using the Data Table editor as a standalone editor.

Save - Saves the current Data Table with its current name.  Ac-
cessible only when using the Data Table editor as a standalone
editor

Cut - Removes the selected text and places it on the Clipboard

Copy - Copies the selected text and places it on the Clipboard

Paste - Inserts the contents of the Clipboard in the Data Table.

Rows: - Indicates the number of rows in the Data Table.

Cols: - Indicates the number of columns in the Data Table.

Help Button - Gives you information about parts of the Data Table
editor screen and Toolbar.

To hide or display the Toolbar, choose Toolbar from the View menu.

IMPORTANT! After you specify the size of a Data Table, you must select Data Table from the View
menu in the Quickstep editor to create the Data Table.  Otherwise, the Quickstep editor
does not create the Data Table at compile time.  You must do this even if you are plan-
ning to use CTCMON or another utility to download information to the Data Table in the
controller.

Changing Column Size
You can change the size of the columns and message display area on the Data
Table by moving the column dividers.  To change the column size:

1. Place the mouse pointer on the divider.

2. When the double arrowhead symbol appears, press the mouse button and
move the column divider.
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3. Release the mouse button when the column divider is in the correct location.

NOTE: You can also move the dividers between the columns.

Changing the Number of Rows and Columns
You can change the number of columns and rows in a Data Table.  To change the
rows and columns:

1. Place the cursor in the Rows: field by selecting it with the mouse pointer or
by using the Tab key.

2. Enter the new number of rows in the table and press Enter.

The Data Table editor changes the number of rows and the cursor highlight
moves to the Cols: field.

3. Enter the new number of columns in the table and press Enter.

The Data Table editor changes the number of columns in the Data Table.

IMPORTANT! • The value of all the cells in a new Data Table are set to zero.

• If you re-size a Data Table by making it smaller, any information in the rows and/or
columns outside of the re-sized Data Table is lost.

• If you re-size a Data Table by making it larger, the cells in the new rows and/or
columns are set to zero.

Data Table Editor Overview
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Saving a Data Table
The Quickstep editor automatically saves the Data Table when it saves your
Quickstep program, using the same name you specified for your Quickstep
program.

When using the Data Table editor in conjunction with the Quickstep editor the
Save options on the File menu and Toolbar are grayed out.  We recommend
saving your Quickstep program several times during an editing session.

NOTE: When using the Data Table editor as a standalone editor, you must save your Data Table using
the Save options on the File menu or on the Toolbar.

Changing the Font
The Data Table editor displays text in Courier New font. You can change the
default font using the Font dialog box.

1. Select Font from the Options menu.

The Fonts dialog box appears.

2. Select the Font, Font Style, Size, and Color.

The Sample box displays the current font.

NOTE: We do not recommend selecting the Strikeout or Underline effects.

3. Select OK to apply your changes.

To exit with out saving your changes, select Cancel.
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Entering Numbers in the Data Table
You can enter a number by typing from the keyboard or pasting it from the
Clipboard.

To enter a value:

1. Place the cursor in the appropriate cell by selecting it with the mouse pointer
or by using the Tab and Arrow keys.

The Data Table editor highlights the cell.

2. Type or paste the number and press Enter.

3. To enter a value in another cell:

• Press Enter to move to the next column in the row.
• Use the Arrow keys to move to the another cell.
The Data Table editor highlights the cell.

Entering Messages in the Data Table
You can enter a message in Message field in the Data Table editor by typing.

NOTE: The length of message (letters, numbers, and spaces) cannot be longer than the number of
columns in the table.

To enter a message:

1. Select the Message field using one of the following methods:

• Place the mouse cursor on the Message field and double click the
mouse.

• Highlight the Message field using the mouse or Tab and Arrow keys
and click it with the mouse.

• Highlight he Message field using the mouse or Tab and Arrow keys
and start typing your message.

Entering Information in the Data Table
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The Data Table editor expands the field.

NOTE: The dots in the message indicate that the corresponding cell in the Data Table does not contain
a number which is an ASCII code for a printing character.

2. Type the message and press Enter.

3. To enter a message in another field, use the Arrow keys to move that field.

The Data Table editor highlights the field.
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Editing Information in the Data Table
Editing Numbers in the Data Table

You edit an entry in the table by selecting the cell and entering the new number.

To edit a table entry:

1. Place the cursor in the appropriate cell by selecting it with the mouse pointer
or by using the Tab and Arrow keys.

2. Type or paste the number and press Enter.

3. To edit a value in another cell:

• Press Enter to move to the next column in the row.
• Use the Arrow keys to move to another cell.
The Data Table editor highlights the cell.

Editing Messages in the Data Table
You edit a message by selecting the message and editing it.

To edit a message:

1. Select the appropriate Message field using one of the following methods:

• Place the mouse cursor on the Message field and double click the
mouse.

• Highlight the Message field using the Tab and Arrow keys and click it
with the mouse.
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he editor displays the entire message.

2. Position the cursor on the part of the message you want to edit.

NOTE: The dots in the message indicate that the corresponding cell in the Data Table does not contain
a number which is an ASCII code for a printing character.

3. Press the Backspace key to delete that part of the message.

4. Type the corrections and press Enter.

6. To edit or enter a message in another field, use the Arrow keys to move to
that field.
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Printing a Data Table
You can print a Data Table:

1. Select Print from the File menu.

2. When the Print dialog box appears, choose the options you want.

3. To print the Data Table in Landscape mode, select Setup.

4. When the Setup dialog box appears, select Landscape.

NOTE: You can also choose other print setup options you want at this time.

5. Choose Ok to return to the Print dialog box.

6. Select Ok to print the Data Table.
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Using the Data Table Editor as a Standalone Editor
In some cases you may want to enter values or messages in the Data Table
before activating the Quickstep editor.  To do this you must use the Data Table
editor as a standalone editor.

The steps for creating a Data Table using the Data Table editor as a standalone
editor are as follows:

• Activate the Data Table editor

• Enter values and messages in the table.

• Save the Data Table using a different name than the Quickstep program you
are planning to write.

Activating the Data Table Editor and Opening a Data Table
1. To activate the Data Table editor, chose one of the following methods:

• Using the File Manager:

a. Open the File Manager and select the directory where the Quickstep
2.0 files are stored.  The default directory is C:\QSWIN.

b. Place the mouse pointer on the file labeled dtable.exe and double
click the mouse.

• Using the Program Manager:

a. Following the instructions provided with Microsoft Windows, create
an icon for Data Table editor in the Quickstep group in the Program
Manager.

b. Activate the Data Table editor by selecting the icon as you would
any Microsoft Windows program icon.

The Load Data Table dialog box appears.

2. To open a Data Table, choose one of the following methods:

• To create a new Data Table, select Cancel on the Load Data Table
dialog box.

• To open an existing Data Table, choose the name of the Data Table from
the Load Data Table dialog box and select OK.  If the Data Table is in a
different directory, select the appropriate directory.



7-12 QuickstepTM User Guide
Control Technology Corporation proprietary. Reproduction or distribution forbidden.

Using the Data Table Editor as a Standalone Editor

Specifying the Number of Rows and Columns
When you create a new Data Table using the Data Table editor as a standalone
editor, the new table has 0 rows and columns.  You specify the rows and columns
as follows:

1. Place the cursor in the Rows: field by selecting it with the mouse pointer or
by using the Tab key.

2. Enter the number of rows in the table and press Enter.

The cursor moves to the Cols: field.

3. Enter the number of columns in the table and press Enter.

The table displays the rows and columns
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IMPORTANT! • The value of all the cells in a new Data Table are set to zero.

• If you re-size a Data Table by making it smaller, any information in the rows and/or
columns outside of the re-sized Data Table is lost.

• If you re-size a Data Table by making it larger, the cells in the new rows and/or
columns are set to zero.

Saving a Data Table
Once you have specified the values and messages in a Data Table you must save
your file.  The file must have a different name than the Quickstep program you
are planning to write.  When the Quickstep editor creates a new program file, it
overwrites any Data Table with the same name as the program file.

Saving a New Data Table
To save a new Data Table:

1. Do one of the following:

• Select Save as from the File menu.
• Select the Save icon on the Toolbar.

The Save Data Table dialog box appears:

2. Enter a name for the new file.

REMEMBER! The file must have a different name than the Quickstep program you are planning to
write.

3. If you want to save the Data Table in a different directory, select the appro-
priate directory.

4. Select OK.
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Saving an Existing Data Table
To save an existing Data Table:

Do one of the following:

• Select Save from the File menu (shortcut, type CTRL + S).
• Select the Save icon on the Toolbar.

Exiting the Data Table Editor
When using the Data Table editor as a standalone editor, you must exit it before
you start the Quickstep editor.  The editor will then reactivate the Data Table
editor.  The only time you should exit the Data Table editor is when you are
using it as a standalone editor.

To exit a standalone Data Table editor:

1. Select Exit from the Edit menu.

If you have not saved your most recent changes the following dialog box
appears:

2. Select the appropriate choice.

Using the Data Table Editor as a Standalone Editor
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Compiling a Quickstep Program
You must compile a Quickstep program before downloading it to a controller.

If you did not enter the location (pathname) of the Quickstep editor files in your
AUTOEXEC.BAT file on your computer during installation, you must do so
now before compiling.  The default installation directory is C:\QSWIN, and the
AUTOEXEC.BAT file is located in C:\.

1. Enter set QSWIN=pathname in your AUTOEXEC.BAT file:

2. Reboot your computer.

Compiling a Program
You compile your Quickstep program from the Quickstep editor.  The editor
notifies you if your program has compiled successfully or not. To compile a
Quickstep program, choose Compile from the View menu.

• The following window appears (temporarily):

• If your program is compiled successfully, the following window appears:

Using the Cross-Reference List
When the Quickstep editor successfully compiles your program, it creates a
cross-reference list.  This list contains the name of every controller resource, I/O
and motion control device in your program.  Instead of listing your symbolic
names, the list shows the internal names used by the controller.

The Cross-reference list shows each use of the internal name on a separate line.
The cross-reference list is shown below.  To display the cross-reference list,
choose Xref from the View menu.
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NOTE: When the CTC Utilities for Windows package becomes available, you will be able to use it to
view the cross-reference list with symbolic names.

Viewing Complier Errors

After compiling a program, the editor notifies you if your program compiled
successfully or not.  If a program has errors, the Quickstep editor displays the
compile error log. The compile error log shows each error on a separate line,
along with a link to the step where the error occurs. To go to an error, select the
step number with the mouse.
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After compiling a Quickstep program, you can download it to your controller.
You can use either serial or ethernet communications to download programs.  To
download your program successfully:

• Make sure the controller model you download your program to is the same
one specified in the Parameter editor.

• Compile your program.

• If you are using the CTCMON Monitor Utility, suspend it.  You cannot
download a program with the CTCMON Monitor Utility active.

• Make sure your controller is turned on and connected to your PC.

• Specify either serial or ethernet communications

For serial communications, you must specify the following parameters before
you download your program:

• Port used: COM1 to COM8.
• Baud rate: speeds from 300 to 19200

For ethernet communications, you must specify the following Node IDs before
you download your program:

• Node ID of the host PC:  You must assign the Node ID of the host PC.  Each
host PC must have a unique Node ID, and it can range from 1 to 999.

• Node ID of the target controller:  If you do not know the controller’s Node
ID, use the CTCMON Monitor Utility to read the value stored in register
20,000.  This is the Node ID for the controller.

The editor notifies you if your program downloaded successfully or not.

Downloading a Program
Once you have compiled your Quickstep program, you can download it to your
controller.  To download a Quickstep program:

1. Choose Download from the View menu.

The Download dialog box appears

2. Click the arrow on the right side of the Type field and select either Serial or
Ethernet communications.

Downloading a Program to the Controller
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3. Do one of the following:

• For serial communications, click the arrow on the right side of the Port,
and Speed fields to select the communication port, and baud rate.

• For ethernet communications, specify the Node ID for the Host PC and
Target controller.

4. Select Download.

If your program downloads successfully, the following window appears:
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Before You Install Quickstep
General Information

Your Quickstep 2.0 package contains the following items:

• Two disks containing the QSSETUP.EXE program, README.WRI, and
the WG1001 subdirectory.  QSSETUP.EXE includes the Quickstep editor,
compiler, download program, and Windows help files.

• One disk containing the MONSETUP.EXE program.  MONSETUP.EXE
includes Control Tech’s controller monitor utility, CTCMON, and its Win-
dows help file.

• The Release Notes.

• Copies of the QuickstepTM Language and Programming Guide and the
QuickstepTM User Guide.

System Requirements
Recommended System Configuration
 The recommended system requirements are as follows:

• 486, 8.0 Mbytes RAM, 9.5 Mbytes of free disk space.
• 1024 x 768 or 800 x 600 SVGA display
• Microsoft Windows 3.1 or higher.

Minimum System Configuration
The minimum system requirements are as follows:

• 386/25 MHz, 4.0 Mbytes RAM, 6.0 Mbytes of free disk space.
• Any Windows compatible display
• Microsoft Windows 3.1 or higher.

Additional Requirements
In addition to the system requirements, you should have basic knowledge of how
to operate Microsoft® Windows as a user.

Reporting Bugs
Bug report forms are supplied with the Release Notes.  Please fill them out and
either fax them to (508) 435-2373 or email bug reports to help@control.com for
Quickstep bugs or to techpubs@control.com for documentation bugs and
comments.  Copies of the Bug report forms are also supplied in BUGRPT.WRI.
You can print them out using Micorsoft Write.
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Installing Quickstep
Installation Procedures

You install the Quickstep editor software from Windows as follows:

1. Insert Disk 1 of QuickstepTM 2.0 for Windows into drive A or B.

2. Open the File menu on the Program Manager and choose the Run com-
mand.

3. Type A:\QSSETUP (type B:\QSSETUP if you are using drive B) in the
Command Line text box and press ENTER or select OK.

4. When the Select Destination Directory dialog box appears, specify the
directory you want to contain the Quickstep editor (default is C:\QSWIN)
and select OK or press Enter.

5. When the Customer Identification dialog box appears, enter the registration
information and select OK.

IMPORTANT! Quickstep licenses are typically sold as site licenses, valid for any number of users within
a single facility.  Also available are media and documentation kits, which contain disks
and manuals, but do not convey any additional licenses.  If you are installing your
facility’s site license, make careful note of the serial number on your registration card and
return the reply portion of the registration card to Control Technology Corporation.

If you are installing a secondary copy using a media kit, refer to the holder of the original
license within your facility for the serial number or contact Control Technology Corpora-
tion to determine that the license was properly registered.  Keep your part of the registra-
tion card; it is the only place the serial number appears.

6. When QSSETUP displays a dialog box listing the information you just
entered, select OK if it is correct or NO to correct it.

7. When the system prompts you, place disk two into the floppy drive and
select OK.

8. When the Select Program Group dialog box appears, specify the program
manager group you want Quickstep to be in (default is Quickstep) and select
OK or press Enter.

QSSETUP.EXE displays the AUTOEXEC.BAT Changes dialog box.  This
dialog box gives you the option of having QSSETUP eautomatically modify
your AUTOEXEC.BAT file to define the environment variable QSWIN or
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modifying it yourself.  This environment variable points to the location of
the Quickstep editor and its associated files.

8. Select one of the following:

• Make the changes for me
• Let me make the changes

If you have QSSETUP make the change to the AUTOEXEC.BAT file,
follow these instructions.  See page A-6 if you choose to make the
changes yourself.
9. Select OK or press Enter.

QSSETUP displays the following message:

If QSWIN is not already defined you will need to reboot your PC before
compiling a program.

10. Select OK or press Enter.

QSSETUP displays the following message:

This system must be restarted to complete the installation.  Press the OK
button to restart this computer.  Press Cancel to return to Windows
without restarting.

11. Do one of the following:

• Select  OK to reboot your PC.
• Select Cancel to return to return to Windows.

IMPORTANT! 1. You cannot compile a Quickstep program until you reboot your PC, unless QSWIN
was already defined as an environment variable in a previous Quickstep 2.0 installa-
tion.

2. If you install Quickstep in a different directory than the one in which you installed a
beta version of Quickstep, you must manually edit your AUTOEXEC.BAT file and
remove the old SET QSWIN=Pathname statement from the file.

Installing Quickstep
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If you elect to change the AUTOEXEC.BAT file yourself, follow these
instructions

NOTE: The default directory used by QSSETUP.EXE for installation is C:\QSWIN.  This example
shows Quickstep being installed in the H:\QS\QSWIN directory.

9. Select OK or press Enter.

QSSETUP displays the following message:
Please add the following line to your AUTOEXEC.BAT file before you
reboot your PC:  set QSWIN=H:\QS\QSWIN.

10. Select OK or press Enter.

QSSETUP displays the following message:
If QSWIN is not already defined you will need to reboot your PC before
compiling a program.

11. Select OK to return to Windows.

IMPORTANT! 1. You cannot compile a Quickstep program until you reboot your PC, unless QSWIN
was already defined as an environment variable in a previous Quickstep 2.0 installa-
tion.

2. If you install Quickstep in a different directory than the one in which you installed a
beta version of Quickstep, you must manually edit your AUTOEXEC.BAT file and
remove the old SET QSWIN=Pathname statement from the file.
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For Windows 3.11/Serial Communications Users
Intermittent Communications with your Controller

When you use Windows for Workgroups version 3.11 with serial communi-
cations, you may experience the following problems:

• If you are using a PentiumTM-based machine with a 16550 UART chip,
your system stops responding (hangs) if there is data in the chip when
the serial communications application attempts to open the communica-
tions port.

A problem with the 16550 UART implementation causes the chip to
become trapped in a mode in which data is always detected in its FIFO
buffer.

• When you are using communications software, you may be able to make
one connection after starting Windows for Workgroups, but any subse-
quent connections fail and may hang your system.

This problem occurs when SERIAL.386 sends an extra NUL character
through the port when the communications software calls the
CloseComm application program interface (API) function. While this
does not normally cause problems, your second connection may fail
with some modems.

The WG1001 subdirectory on Disk 2 contains an updated SERIAL.386
driver from Microsoft that corrects both of these problems.



Appendix A - Installation Instructions A-7

Control Technology Corporation proprietary. Reproduction or distribution forbidden.

Installation Procedures
You install the CTCMON monitor utility software from Windows as follows:

1. Insert the disk labeled CTCMON into drive A or B.

2. Open the File menu on the Program Manager and choose the Run com-
mand.

3. Type A:\MONSETUP (type B:\MONSETUP if you are using drive B) in
the Command Line text box.

4. Press ENTER or select OK to start the installation.

MONSETUP displays the following message:

This program will install CTC Monitor Utility onto your computer.  Press
the OK button to start the installation.  You can press the Cancel button if
you do not want to install this software.

5. Select OK.

MONSETUP displays the Select Destination Directory dialog box.

5. Specify the directory you want to contain the CTC Monitor Utility (default
is C:\QSWIN\CTCMON).

If you installed Quickstep in a directory other than C:\QSWIN, you must
install the CTC Monitor Utility in a subdirectory under it called CTCMON.
For example, if Quickstep was installed in H:\QS\QSWIN, install the CTC
Monitor Utility in H:\QS\QSWIN\CTCMON.

6. Select OK or press Enter.

MONSETUP displays a dialog box showing the progress of the installation.

7. When the Select Program Group dialog box appears, specify the program
manager group you want CTC Monitor Utility to be in (default is Quickstep)
and select OK or press Enter.

MONSETUP displays the following message:

CTC monitor installation finished!

8. Select OK.

Installing the CTCMON Monitor Utility
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Glossary
Controller Resources

Control Tech controllers provide the following internal controller resources
you can use when writing your Quickstep program:  special and general
purpose numeric registers, counters, flags, and Data Table.

Counters
Counters allow the automatic counting of pulses from the controller’s inputs.
They work in the background and, once started, operate much like an
independent device within the controller.

Data Destination
A data destination is a controller resource (register or counter), specialized I/
O device (analog output or display), or Data Table column which accepts a
numeric value.  A data destination is one of the choices that appears in the
Selection bar when programming Quickstep instructions.

Data Source
A data source supplies a numeric value.  It can be a numeric constant or the
value derived from a counter, register, analog input, thumbwheel, or Data
Table column.  A data source is one of the choices that appears in the
Selection bar when programming Quickstep instructions.

Data Table
The Data Table is a two-dimensional array of numbers that can be stored in
the controller’s memory along with your Quickstep program.  Storing this
information in the Data Table instead of within the body of a program makes
the program easier to maintain.  The size of the Data Table depends on the
controller model.

Dedicated Inputs
Dedicated inputs are functions that can be programmed for certain controller
inputs.  They are called Start, Stop. Reset, and Step.  For additional informa-
tion on dedicated inputs, refer to the QuickstepTM Language and Program-
ming Guide.

Editing Window
The Editing window is the part of the Quickstep editor where you view and
edit your file.

Flags
Flags are memory elements within a controller that can be either set or clear
and are used to store yes/no types of information.

List of Symbolic Names
The Symbol Browser displays the symbolic names in a list.  Only the
symbolic names for the selected symbol type appear.

Numeric Source
A numeric source supplies a numeric value.  It can be a servo position or
error, a numeric constant, or the value derived from a counter, register,
analog input, thumbwheel, or Data Table column.  A numeric source is one
of the choices that can appear in the Selection bar when programming
Quickstep instructions.

Numeric Registers
Numeric Registers are storage locations for numbers within your controller.
Special purpose registers perform specific functions, depending on the
register number and the value stored in it.
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For the storage capacity of the general purpose registers and a list of the
special purpose registers and their functions, refer to the QuickstepTM

Language and Programming Guide and the installation instructions for your
controller model.

Parameter Editor
Use the Parameter editor to specify the following information:

• The model of your controller
• The number of rows and columns in data table
• Which, if any, of the first four inputs are used for dedicated functions

Placeholders
The placeholders indicate where you need to enter information while you are
writing your Quickstep program.  Examples are as follows:

• Comment line placeholders <<Comment Line>>
• Output change placeholders <<Output Change>>
• Instruction placeholders <<Statements>>
• Data Source placeholders <<Data Source>>
• Servo Name placeholders <<Servo Name>>

Registers (see Numeric Registers)
Resource Delay

A resource delay is any controller resource or specialized I/O device that
provides the value for a Delay instruction.  It is one of the choices that can
appear in the Selection bar when programming Quickstep instructions.

Servo Value
A servo value is the servo position or error of a servo.  It is one of the
choices that can appear in the Selection bar when programming Quickstep
instructions.

Source Code
Step headers (step numbers and names), comments, input/output changes,
and instructions are called source code.  The editor uses the source code in
your Quickstep program to compile the .dso file that you download to your
controller.  Source code lines that have errors in them due to editing or
cutting and pasting are displayed in red text (system default).  Also refer to
the definition for Unparsed Source in this section.

Specialized I/O Devices
Quickstep supports the following specialized input/output devices:

• Analog inputs and outputs
• Thumbwheel arrays
• Numeric displays

Specialized Motion Control Devices
Quickstep supports the following specialized motion control devices:

• Servo motors
• Stepping motors
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Symbol Browser
Use the Symbol Browser to specify symbolic names for steps, numeric
constants and the following controller resources and special devices:

• Analog inputs
• Analog outputs
• Counters
• Data Table columns
• Displays
• Flags
• Inputs
• Outputs
• Stepping motors and servos
• Numeric registers
• Thumbwheels

Symbol Type
A Symbol type defines the nature of the object being referred to by a sym-
bolic name.  For example, the symbolic name Spindle_Motor might have a
symbol type of servo.  Symbol types are listed on the left side of the Symbol
Browser.

Templates (see Placeholders)
Undefined Steps

Undefined Steps are step names that have not been used in a Quickstep
program.  Once an undefined step name is used in a Quickstep program, it
becomes a step name with a step number and is listed as a Step in the
Symbol table.

Unparsed Source
Unparsed source is any line in a Quickstep program that contains errors or
has not been checked by the Quickstep editor.  Unparsed source is displayed
in red text (system default).  See also: Source Code

Glossary
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